This topic contains 5 replies, has 2 voices, and was last updated by  admin 5 years, 7 months ago.

  • Author
  • #75235

    Clive Smith

    Think I’m missing something on the adding a data source


    Cant seem to connect to our data file can only see the so simple Calendar one



  • #75240


    Have you gone through the integration step-by-step?

    Five Minute Integration (server-powered)

    Make sure the user name and password is correct in the data source set up and that the assigned user has FMPHP extended privilege set in your data source. (and FMREST, too, if you’re using that).

  • #75245


    Please see my previous reply. I’ve merged your two questions, as they’re really the same.

  • #75258


    I’ve merged the questions again. Please reply to this thread rather than creating a new thread.

    I didn’t see that you were using an alternate port – I see now that we had a brief correspondence via email.

    I assume you’re using FileMaker 16 or earlier? I do not believe that FMS17 allows custom ports. Or are you redirecting ports using a different method?

    Did you change the port in the Data Source setup as per our email exchange?

    Assuming you’re hosting on a single-server (PHP on the same address as FileMaker server), for alternate ports:

    • change the config.php file in your php directory to: “<your fqdn here>:<port#>”. Watch out for breaking the straight quotes.
    • change the “URL to php” field in soSIMPLE Calendar Settings to “https://<your fqdn here>/sosimple/sosimple_cal.php:<port#>”
    • change the Data Source Host from Single Server to “<your fqdn here>:<port#>”

    If you have multiple servers, the instructions will differ.

    Full reference for this is here:

  • #75241

    Clive Smith

    Hi again


    OK getting closer, think the PHP side is working and added the file and selected fields but no events showing on calendar

  • #75256

    Clive Smith


    I’ve followed all the setup files and all looks ok but no events showing

    any ideas on where to look to see where the error is.

    I’ve gone through the setup instructions a few times edited the php config files and added the port.

    Not seeing any errors just no events.

    the PHP service is on a different port 8040 so data files are on <fqdn>:8040 or 44340

    • This reply was modified 5 years, 7 months ago by  admin.
    • This reply was modified 5 years, 7 months ago by  admin. Reason: hide actual address

You must be logged in to reply to this topic.