This topic contains 3 replies, has 2 voices, and was last updated by  admin 5 years, 1 month ago.

  • Author
  • #71401

    “Open by double-click” does not trigger anything but a blank webviewer (in fact, this is the only action I am running from the calendar). It has all worked well before, and I *think* (not sure) the problem started when I installed FileMaker 14 on my system several weeks ago, but did not pursue it that time.

    So when I started working on the calendar again a week ago I first uninstalled FM 14. Now the “fmp12” file extension is connecting correctly to FM 13. But the problem persists.

    I checked the settings in CalendarSettings.fmp12, esp. a script being connected as Action Script and so forth. Again, everything else is working ok. But the only action is a blannk webviewer page.

    (this is FM 13 on Windows 8.1, Internet Explorer v.11)

    I am puzzled … any idea??


  • #71402


    Hi Jo –

    What version of soSIMPLE are you using?

    Also, have you changed any field names or layout names?

    The top of the soSIMPLE Action Script sets up three variables that the rest of the script is dependent on. This includes event id, date & time, etc. Try this and tell me how it works:

    Open soSIMPLE Settings file and navigate to your calendar.
    Click “Use In FileMaker Pro”
    Click “Copy just Variable Steps”

    Now go to your action script in your solution, and paste these steps in place of your existing “set variable” script steps.

    Let me know how that works.



  • #71403

    hi Ken —
    Calendar Version: 3.13, 20150918.
    Status: solved

    I did as you suggested, but no difference. I then tested everything on another machine of mine, and bingo … working! That go me on the right track. To make things short: I reinstalled FM 13, and done. The uninstallation of FM 14 had cut the internal connection to the fmp12 file extension (my previous test of opening a file in FM by double-clicking it is obviously not a simulation of what the calendar does to address a FM file). Well, I don’t think FileMaker ever won a prize for observing OS standards, at least not for Windows.

    So, thanks for your prompt support, Ken!

  • #71404


    Thanks for the update Jo. I’m glad you got it working.

    We’ve seen this come up from time to time with developers, but rarely with end-users, because developers tend to install multiple versions of FileMaker on their system. This is why:

    When you double-click an event, soSIMPLE uses the FMP: protocol to run the action script. That is it calls a url like: “fmp://x.x.x.x/your_solution?script=yourscript”.

    Anytime you install FileMaker, the protocol preference is set up on your computer to open the version of FileMaker that’s being installed. So if you’re installing FMP14, the protocol will be set up to always open FMP14 (when opening an event in soSIMPLE for example). If you later open an already-installed FMP13, double-clicking one of your events might open FMP14. If you uninstall FMP14, then nothing will open. It sounds like that’s what’s happened to you.

    There are workarounds to this that are good for developers to know about:
    For Mac: RCDefaultApp
    For Windows: Edit the registry for [HKEY_CLASSES_ROOT\FMP\shell\open\command] to point to the right installation of FileMaker.

    Please always backup and be careful anytime you edit the registry.

You must be logged in to reply to this topic.